Как установить 64-х битный Adobe flash плагин в Ubuntu

flash playerЕсли Вам нужно просто поставить Adobe Flash плагин, чтобы в браузере заработало flash-видео или ещё что-то, то можно выполнить простую команду

sudo apt-get install adobe-flashplugin

или нажать на ссылку, чтобы установить через центр приложений.

Однако, если Вам понадобилась 64-х битная версия флеш-плагина — тут всё не так просто.

Вообще, печально, что производители проприетарного софта так разленились: для 64-х битных систем выпускают 32-х битные приложения, обёрнутые во всякие адаптеры (врапперы) и делают вид, что так и надо. Но это плохо сказывается и на скорости и на стабильности.

64-х битная версия adobe flash plugin в природе существует. Лежит она в ppa sevenmachines/flash. Значит, чтобы нам её поставить нужно:

  1. Добавить ppa.
  2. Обновить пакеты.
  3. Удалить 32-х битную версию.
  4. Поставить 64-х битную.

Всё это делается командами:

sudo add-apt-repository ppa:sevenmachines/flash
sudo apt-get update
sudo apt-get remove flashplugin-installer nspluginwrapper
sudo apt-get install flashplugin64-installer

После чего в Вашем 64-х битном браузере будет работать 64-х битный флеш-плагин.

Поделиться заметкой:
  • scat

    Не удалось найти пакет flashplugin64-installer — последнее сообщение терминала(((

  • mint

    Не удаётся добавить PPA: «No JSON object could be decoded».
    Mint15 Mate